Campus Solutions (Student Center and Faculty Center) and Human Resource Peoplesoft systems going down for Maintenance tonight (9/2/26) 6-10pm

Incident Report for Cal Poly Humboldt System Status

Resolved

All systems are back and working.
Posted Sep 02, 2026 - 21:08 PDT

Identified

From 6-10pm tonight we will be installing MP32 and MP32.01 into Campus Solutions and bouncing the Human Resources servers.
Posted Sep 02, 2026 - 08:48 PDT
This incident affected: PeopleSoft Campus Solutions AND PeopleSoft HR systems.